Back to overview
Resolved
Settlement Delays
Aug 11, 2026 at 12:25am UTC
Affected services
app.templedigitalgroup.com
Resolved
Aug 11, 2026 at 11:29pm UTC
Resolved
Affected services
Created
Aug 11, 2026 at 12:25am UTC
There is currently an ongoing issue with an asset provider on Canton that prevents settlements from being executed, we are actively working with our partner to resolve this as quickly as possible. No action required.
Affected services