Back to overview
Degraded

Pending Transaction Delays

Apr 26, 2026 at 9:59pm UTC
Affected services
app.templedigitalgroup.com

Resolved
Apr 27, 2026 at 7:10pm UTC

Update: We are still working towards improve settlement time, currently we are seeing 99% success rate of executions. Our goal is to get settlements down to 1 minute within the next 48 hours.

Created
Apr 26, 2026 at 9:59pm UTC

Investigating delays on transaction executions, expecting an update 04/27.