Back to overview
Degraded

Withdrawal Delays

Apr 26, 2026 at 10:10pm UTC
Affected services
app.templedigitalgroup.com

Updated
Apr 27, 2026 at 12:30am UTC

We've identified the issue — For now make sure to visit cantonloop.com to make sure there are no open withdrawal requests. The issue gets triggered when users have multiple withdrawal requests, working on a fix that should be available by tomorrow 04/27.

Updated
Apr 26, 2026 at 10:47pm UTC

still investigating

Updated
Apr 26, 2026 at 10:26pm UTC

We've shipped some additional optimizations that will help improve transaction success rate.

Created
Apr 26, 2026 at 10:10pm UTC

Investigating an issue that a small number of users reported that prevents them from doing multiple withdrawals during the same session. Expecting resolution by tomorrow.