Back to overview
Degraded

Balance Mismatch After Order Cancelation

Apr 26, 2026 at 10:12pm UTC
Affected services
app.templedigitalgroup.com

Updated
Apr 26, 2026 at 10:57pm UTC

Still looking into this, we are expecting a permanent fix to be applied tomorrow 04/27

Created
Apr 26, 2026 at 10:12pm UTC

Investigating an issue that prevents some users from unlocking their balance after an order is canceled