Back to overview
Degraded
Transaction Cancelations
Apr 26, 2026 at 11:27pm UTC
Affected services
app.templedigitalgroup.com
Resolved
Apr 27, 2026 at 12:04am UTC
Issue Resolved - Transaction cancelation rate has been improved, monitoring less than 2% cancelation rate for the past 24 hours — We are expecting to release more updates to improve stability and reduce cancelation rate within the next 48 hours.
Affected services
Created
Apr 26, 2026 at 11:27pm UTC
investigating a higher than usual cancelation rate for transactions.
Affected services